Ensurepass

CCIE Routing and Switching Written Exam v5.1

 

QUESTION 171

DRAG DROP

clip_image002

 

Correct Answer:

clip_image004

 

 

 

QUESTION 172

Which technology can be used to prevent flooding of IPv6 multicast traffic on a switch?

 

A.

IGMP snooping

B.

IGMP filtering

C.

MLD snooping

D.

MLD filtering

 

Correct Answer: C

Explanation:

MLD snooping allows the switch to examine MLD packets and make forwarding decisions based on their content.

You can configure the switch to use MLD snooping in subnets that receive MLD queries from either MLD or the MLD snooping querier. MLD snooping constrains IPv6 multicast traffic at Layer 2 by configuring Layer 2 LAN ports dynamically to forward IPv6 multicast traffic only to those ports that want to receive it.

Reference: http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst6500/ios/12-2SX/configuration/guide/book/snoopmld.html

 

 

QUESTION 173

Which group of neighbors can be configured as a BGP peer group?

 

A.

a group of iBGP neighbors that have the same outbound route policies

B.

a group of iBGP and eBGP neighbors that have the same inbound distribute-list

C.

a group of eBGP neighbors in the same autonomous system that have different outbound route policies

D.

a group of iBGP neighbors that have different outbound route policies

 

Correct Answer: A

Explanation:

You can group BGP neighbors who share the same outbound policies together in what is called a BGP peer group. Instead of configuring each neighbor with the same policy individually, a peer group allows you to group the policies which can be applied to individual peers thus making efficient update calculation along with simplified configuration.

Reference: http://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/13755-29.html

 

 

QUESTION 174

How many hash buckets does Cisco Express Forwarding use for load balancing?

 

A.

8

B.

16

C.

24

D.

32

 

Correct Answer: B

Explanation:

In order to understand how the load balance takes place, you must first see how the tables relate. The Cisco Express Forwarding table points to 16 hash buckets (load share table), which point to the adjacency table for parallel paths. Each packet to be switched is broken up into the source and destination address pair and checked against the loadshare table. Reference: http://www.cisco.com/c/en/us/support/docs/ip/express-forwarding-cef/18285-loadbal-cef.html

QUESTION 175

Consider a network that mixes link bandwidths from 128 kb/s to 40 Gb/s. Which value should be set for the OSPF reference bandwidth?

 

A.

Set a value of 128.

B.

Set a value of 40000.

C.

Set a manual OSPF cost on each interface.

D.

Use the default value.

E.

Set a value of 40000000.

F.

Set a value of 65535.

 

Correct Answer: C

Explanation:

Unlike the metric in RIP which is determined by hop count and EIGRP’s crazy mathematical formulated metric, OSPF is a little more simple. The default formula to calculate the cost for the OSPF metric is (10^8/BW).

By default the metrics reference cost is 100Mbps, so any link that is 100Mbps will have a metric of  a T1 interface will have a metric of 64 so in this case if a router is trying to get to a FastEthernet network on a router that is through a T1 the metric would be 65 (64 +1).

You do however have the ability to statically specify a metric on a per interface basis by using the ip ospf cost # where the cost is an integer between 1-65535.

So the big question is why would you want to statically configure a metric?

The biggest advantage of statically configuring an OSPF metric on an interface is to manipulate which route will be chosen dynamically via OSPF. In a nut shell it’s like statically configuring a dynamic protocol to use a specific route. It should also be used when the interface bandwidths vary greatly (some very low bandwidth interfaces and some very high speed interfaces on the same router).

 

 

QUESTION 176

Refer to the exhibit. Why is R2 unable to ping the loopback interface of R4?

 

clip_image006

A.

The local preference is too high.

B.

The weight is too low.

C.

The next hop is not reachable from R2.

D.

The route originated from within the same AS.

 

Correct Answer: C

Explanation:

Before a BGP speaker installs a route to a network in the main IP routing table, the router must know how to reach the next hop that is used to get to that network. Route reachability is verified by searching for a route to the next hop in the main IP routing table. Unlike IGP routing protocols, such as EIGRP and OSPF, which assume that a route is reachable if they learned it through a valid adjacency, BGP does not install routes that it cannot verify as reachable. If a route to the next hop for a BGP network is found in the main IP routing table, BGP assumes that the network is reachable, and that the particular BGP route might be stored in the main IP routing table. If the router receives a route to a network that is not reachable, that route continues to be stored in the incoming BGP table, adj-RIB-In, and might be seen using the show ip bgp command, but is not placed in the main IP routing table.

Reference: https://www.informit.com/library/content.aspx?b=CCIE_Practical_Studies_II&seqNum=75

 

 

QUESTION 177

Refer to the exhibit. Which two statements about the device that generated the output are true? (Choose two.)

 

clip_image008

 

A.

The SPT-bit is set.

B.

The sparse-mode flag is set.

C.

The RP-bit is set.

D.

The source-specific host report was received.

 

Correct Answer: AD

Explanation:

In this example we can see that the s, T, and I flags are set. Here is a list of the flags and their meanings:

show ip mroute Field Descriptions

Field

Description

Flags:

Provides information about the entry.

D – Dense

Entry is operating in dense mode.

S – Sparse

Entry is operating in sparse mode.

B – Bidir Group

Indicates that a multicast group is operating in bidirectional mode.

s – SSM Group

Indicates that a multicast group is within the SSM range of IP addresses. This flag is reset if the SSM range changes.

C – Connected

A member of the multicast group is present on the directly connected interface.

L – Local

The router itself is a member of the multicast group.

P – Pruned

Route has been pruned. The Cisco IOS software keeps this information so that a downstream member can join the source.

R – RP-bit set

Indicates that the (S, G) entry is pointing toward the RP. This is typically prune state along the shared tree for a particular source.

F – Register flag

Indicates that the software is registering for a multicast source.

T – SPT-bit set

Indicates that packets have been received on the shortest path source tree.

J – Join SPT

For (*, G) entries, indicates that the rate of traffic flowing down the shared tree is exceeding the SPT-Threshold set for the group. (The default SPT-Threshold setting is 0 kbps.) When the J- Join shortest path tree (SPT) flag is set, the next (S, G) packet received down the shared tree triggers an (S, G) join in the direction of the source, thereby causing the router to join the source tree. For (S, G) entries, indicates that the entry was created because the SPT-Threshold for the group was exceeded. When the J- Join SPT flag is set for (S, G) entries, the router monitors the traffic rate on the source tree and attempts to switch back to the shared tree for this source if the traffic rate on the source tree falls below the SPT-Threshold of the group for more than 1 minute.

M – MSDP created entry

Indicates that a (*, G) entry was learned through a Multicast Source Discovery Protocol (MSDP) peer. This flag is only applicable for a rendezvous point (RP) running MSDP.

X – Proxy Join Timer Running

Indicates that the proxy join timer is running. This flag is only set for (S, G) entries of an RP or “turnaround” router. A “turnaround” router is located at the intersection of a shared path (*, G) tree and the shortest pa
th from the source to the RP.

A – Advertised via MSDP

Indicates that an (S, G) entry was advertised through an MSDP peer. This flag is only applicable for an RP running MSDP.

U – URD

Indicates that a URD channel subscription report was received for the (S, G) entry.

I – Received Source Specific Host Report

Indicates that an (S, G) entry was created by an (S, G) report. This (S, G) report could have been created by IGMPv3, URD, or IGMP v3lite. This flag is only set on the designated router (DR).

 

Reference: http://www.cisco.com/c/en/us/td/docs/ios/12_0s/feature/guide/12s_ssm.html

 

 

 

 

 

QUESTION 178

Refer to the exhibit. Why is the prefix 1.1.1.1/32 not present in the routing table of R1?

 

clip_image010

 

A.

There is a duplicate router ID.

B.

There is a subnet mask mismatch on Ethernet0/0.

C.

The router LSA has an invalid checksum.

D.

There is an OSPF network type mismatch that causes the advertising router to be unreachable.

 

Correct Answer: D

Explanation:

A common problem when using Open Shortest Path First (OSPF) is routes in the database don’t appear in the routing table. In most cases OSPF finds a discrepancy in the database so it doesn’t install the route in the routing table. Often, you can see the Adv Router is not-reachable message (which means that the router advertising the LSA is not reachable through OSPF) on top of the link-state advertisement (LSA) in the database when this problem occurs. Here is an example:

Adv Router is not-reachable

LS age. 418

Options: (No TOS-capability, DC)

LS Type. Router Links

Link State ID. 172.16.32.2

Advertising Router: 172.16.32.2

LS Seq Number: 80000002

Checksum: 0xFA63

Length: 60

Number of Links: 3

There are several reasons for this problem, most of which deal with mis-configuration or a broken topology. When the configuration is corrected the OSPF database discrepancy goes away and the routes appear in the routing table.

Reason 1: Network Type Mismatch

Let’s use the following network diagram as an example:

 

clip_image012 

 

R4-4K

R1-7010

interface Loopback0

ip address 172.16.33.1 255.255.255.255

 

interface Serial2

ip address 172.16.32.1 255.255.255.0

ip ospf network broadcast

 

router ospf 20

network 172.16.0.0 0.0.255.255 area 0

interface Loopback0

ip address 172.16.30.1 255.255.255.255

!

interface Serial1/0

ip address 172.16.32.2 255.255.255.0

clockrate 64000

 

router ospf 20

network 172.16.0.0 0.0.255.255 area 0

R4-4K(4)# show ip ospf interface serial 2

Serial2 is up, line protocol is up

Internet Address 172.16.32.1/24, Area 0

Process ID 20, Router ID 172.16.33.1, Network Type BROADCAST, Cost: 64

Transmit Delay is 1 sec, State DR, Priority 1

Designated Router (ID) 172.16.33.1, Interface address 172.16.32.1

Backup Designated router (ID) 172.16.32.2, Interface address 172.16.32.2

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Hello due in 00:00:08

Neighbor Count is 1, Adjacent neighbor count is 1

Adjacent with neighbor 172.16.32.2 (Backup Designated Router)

Suppress hello for 0 neighbor(s)

 

R1-7010(5)# show ip ospf interface serial 1/0

Serial1/0 is up, line protocol is up

Internet Address 172.16.32.2/24, Area 0

Process ID 20, Router ID 172.16.32.2, Network Type POINT_TO_POINT, Cost: 64

Transmit Delay is 1 sec, State POINT_TO_POINT,

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Hello due in 00:00:02

Neighbor Count is 1, Adjacent neighbor count is 1

Adjacent with neighbor 172.16.33.1

Suppress hello for 0 neighbor(s)

As you can see above, Router R4-4K is configured for broadcast, and Router R1-7010 is configured for point-to-point. This kind of network type mismatch makes the advertising router unreachable.

R4-4K(4)# show ip ospf database router 172.16.32.2

 

Adv Router is not-reachable

LS age. 418

Options: (No TOS-capability, DC)

LS Type. Router Links

Link State ID. 172.16.32.2

Advertising Router: 172.16.32.2

LS Seq Number: 80000002

Checksum: 0xFA63

Length: 60

Number of Links: 3

 

Link connected to: another Router (point-to-point)

(Link ID) Neighboring Router ID. 172.16.33.1

(Link Data) Router Interface address: 172.16.32.2

Number of TOS metrics: 0

TOS 0 Metrics: 64

 

Link connected to: a Stub Network

(Link ID) Network/subnet number: 172.16.32.0

(Link Data) Network Mask: 255.255.255.0

Number of TOS metrics: 0

TOS 0 Metrics: 64

 

R1-7010(5)# show ip ospf database router 172.16.33.1

 

Adv Router is not-reachable

LS age. 357

Options: (No TOS-capability, DC)

LS Type. Router Links

Link State ID. 172.16.33.1

Advertising Router: 172.16.33.1

LS Seq Number: 8000000A

Checksum: 0xD4AA

Length: 48

Number of Links: 2

 

Link connected to: a Transit Network

(Link ID) Designated Router address: 172.16.32.1

(Link Data) Router Interface address: 172.16.32.1

Number of TOS metrics: 0

TOS 0 Metrics: 64

 

You can see that for subnet 172.16.32.0/24, Router R1-7010 is generating a point-to-point link and Router R4-4K is generating a transit link. This creates a discrepancy in the link-state database, which means no routes are installed in the routing table.

 

R1-7010(5)# show ip route

172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks

C 172.16.32.0/24 is directly connected, Serial1/0

C 172.16.30.1/32 is directly connected, Loopback0

 

Solution

To solve this problem, configure both routers for the same network type. You can either change the network type of Router R1-7010 to broadcast, or change Router R4-4K’s serial interface to point-to-point.

Reference: http://www.cisco.com/c/en/us/support/docs/ip/open-shortest-path-first-ospf/7112-26.html

 

 

QUESTION 179

DRAG DROP

clip_image014

 

Correct Answer:

clip_image016

 

 

QUESTION 180

What is the preferred method to improve neighbor loss detection in EIGRP?

 

A.

EIGRP natively detects neighbor down immediately, and no additional feature or configuration is required.

B.

BFD should be used on interfaces that support it for rapid neighbor loss detection.

C.

Fast hellos (subsecond) are preferred for EIGRP, so that it learns rapidly through its own mechanisms.

D.

Fast hellos (one-second hellos) are preferred for EIGRP, so that it learns rapidly through its own mechanisms.

 

Correct Answer: B

Explanation:

Bi-directional Forwarding Detection (BFD) provides rapid failure detection times between forwarding engines, while maintaining low overhead. It also provides a single, standardized method of link/device/protocol failure detection at any protocol layer and over any media.

Reference: “Bidirectional Forwarding Detection for EIGRP”

http://www.cisco.com/en/US/technologies/tk648/tk365/tk207/technologies_white_paper0900aecd8 0243fe7.html

 

Free VCE & PDF File for Cisco 400-101 Practice Test

Instant Access to Free VCE Files: CCNA | CCNP | CCIE …
Instant Access to Free PDF Files: CCNA | CCNP | CCIE …